Total War: WARHAMMER II native release date

total war warhammer ii linux and mac release date

Total War: WARHAMMER II finally has a release date on Linux and Mac. So thanks to Feral Interactive who are announcing the good news. Expect to be able to jump into Total War: WARHAMMER II, the second instalment of the epic fantasy strategy series. Expect to see Total War: WARHAMMER II releasing for Linux and Mac on November 20th.

Originally developed by Creative Assembly in partnership with Games Workshop and published by SEGA for Windows. This is the follow up to the critically-acclaimed Total War: WARHAMMER. And also coming to Linux and Mac by Feral Interactive, over a year since the original release.

Total War: WARHAMMER II — Coming to Linux and Mac November 20th

Total War: WARHAMMER II puts players in command of one of four fantastical Races. While challenging them to wage a war of conquest in order to stabilise or disrupt the apocalyptically powerful Great Vortex. The engrossing narrative campaign takes place across four strikingly distinct continents. These are the tropical Lustria, icy Naggaroth, the mountainous, ring-shaped Isle of Ulthuan. And also the deserts, jungles and savannahs of the sprawling Southlands.

Also due note that the next weeks release will be Vulkanized. According to the previous statement via Twitter released back in September. So the fact that we have that confirmation creates some further excitement for the coming launch. And also helps to level up overall gameplay. Since the previous Total War: WARHAMMER Linux build also comes with Vulkan support.

Pre-order before the release date:

Total War: WARHAMMER II for Linux and Mac is available on Steam and Humble Store. But pre-order’s are also live on the Feral Store for $59.99/£39.99/€59.99.

Linux system requirements:

OS: Ubuntu 18.04 64-bit
Processor: Intel Core i3-4130 @ 3.4GHz
GPU: 2GB Nvidia GTX 680 or better, 2GB AMD R9 285 (GCN 3rd Gen) or better
System RAM: 6GB RAM
Storage: 52GB

Additional Notes:

  • Nvidia graphics cards require driver version 396.54 (tested)
  • AMD graphics cards require Mesa 18.1.5 or better (tested)
%d bloggers like this: